Skip to main content
← All vulnerabilities
CVE-2024-57726

SimpleHelp remote support software v5.5.7 and before has a vulnerability that allows low-privileges technicians to create API keys with exce

SimpleHelp 5.5.7 and all earlier releases are affected, and a low-privilege technician can promote themselves to server admin. The fix is in 5.5.8.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 5.5.8
None on Exploit-DB, Metasploit or GitHub

Summary

SimpleHelp, a remote support software product, is affected by a flaw that lets low-privileged technicians create API keys with more permissions than they should have. An attacker could use these keys to gain server administrator access.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

SimpleHelp remote support software v5.5.7 and before has a vulnerability that allows low-privileges technicians to create API keys with excessive permissions. These API keys can be used to escalate privileges to the server admin role.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • n/a n/a

    Version range not reported

References 2

horizon3.ai

simple-help.com

FAQ

Questions about CVE-2024-57726

What does this mean?

A technician with low privileges can create API keys with more access than they should have. That lets them promote themselves to server admin, and as admin they can take over the SimpleHelp server.Source: guides.simple-help.com, horizon3.ai

Am I affected, and how do I check?

SimpleHelp version 5.5.7 and all earlier releases are in scope. To check, compare the installed SimpleHelp version number against 5.5.7.Source: guides.simple-help.com, horizon3.ai

What should I do about it?

Upgrade to SimpleHelp 5.5.8 or later, which resolves these vulnerabilities.Source: guides.simple-help.com, horizon3.ai

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-04-24, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data