RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms
Only affects Craft CMS 3.0.0 to 3.9.14, 4.0.0-RC1 to 4.13.2, and 5.0.0-RC1 to 5.5.2 when PHP's register_argc_argv setting is enabled. Fixed in 3.9.14, 4.13.2, and 5.5.2.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 4.13.2, 5.5.2, 3.9.14
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Craft CMS, a content management system for building websites, is affected when the PHP setting `register_argc_argv` is enabled in its configuration. This could allow an attacker to remotely execute arbitrary code on the affected server.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Users of affected versions are affected by this vulnerability if their php.ini configuration has `register_argc_argv` enabled. For these users an unspecified remote code execution vector is present. Users are advised to update to version 3.9.14, 4.13.2, or 5.5.2. Users unable to upgrade should disable `register_argc_argv` to mitigate the issue.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- craftcms cms
From 4.0.0-RC1 · fixed in 4.13.2; From 5.0.0-RC1 · fixed in 5.5.2; From 3.0.0 · fixed in 3.9.14
- craftcms/cmsPackagist
From 5.0.0-RC1 · fixed in 5.5.2
- craftcms/cmsPackagist
From 4.0.0-RC1 · fixed in 4.13.2
- craftcms/cmsPackagist
From 3.0.0 · fixed in 3.9.14
References 2
GitHub · craftcms/cms
Questions about CVE-2024-56145
What does this mean?
The bug allows remote code execution, meaning code could run on the server, when PHP's register_argc_argv setting is enabled.Source: github.com
Am I affected, and how do I check?
Craft CMS 3.0.0 up to 3.9.14, 4.0.0-RC1 up to 4.13.2, and 5.0.0-RC1 up to 5.5.2 are listed as affected. The issue depends on register_argc_argv in php.ini, which can be checked there or with phpinfo().Source: github.com
What should I do about it?
Update to 4.13.2 or 5.5.2, or to 3.9.14 for the 3.x line. Until then, disabling register_argc_argv if it is enabled is the listed workaround.Source: github.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-06-02, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data