Skip to main content
← All vulnerabilities
CVE-2024-55591

An Authentication Bypass Using an Alternate Path or Channel vulnerability [CWE-288] affecting FortiOS version 7.0.0 through 7.0.16 and Forti

Affects FortiOS 7.0.0 through 7.0.16 and FortiProxy 7.0.0 through 7.0.19 and 7.2.0 through 7.2.12. No vendor severity is given, and the FortiOS fix is 7.0.17 or above.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
None on Exploit-DB, Metasploit or GitHub

Summary

This vulnerability affects Fortinet's FortiOS and FortiProxy operating systems used in their network security appliances. An remote attacker could exploit it by sending specially crafted requests to a websocket component, gaining full administrator privileges on the affected device.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

An Authentication Bypass Using an Alternate Path or Channel vulnerability [CWE-288] affecting FortiOS version 7.0.0 through 7.0.16 and FortiProxy version 7.0.0 through 7.0.19 and 7.2.0 through 7.2.12 allows a remote attacker to gain super-admin privileges via crafted requests to Node.js websocket module.

Timeline

  1. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  2. CVE published
  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Fortinet FortiOS

    From 7.0.0 · through 7.0.16

  • Fortinet FortiProxy

    From 7.2.0 · through 7.2.12; From 7.0.0 · through 7.0.19

References 1

fortiguard.fortinet.com

FAQ

Questions about CVE-2024-55591

What does this mean?

Crafted requests to the Node.js websocket module, or crafted CSF proxy requests, can let a remote attacker gain super-admin privileges. The attacker could then create admin and local user accounts and log in to SSL VPN to reach the internal network.Source: fortiguard.fortinet.com

Am I affected, and how do I check?

FortiOS 7.0.0 through 7.0.16 is listed as affected, and so are FortiProxy 7.2.0 through 7.2.12 and FortiProxy 7.0.0 through 7.0.19. Compare the installed version against these ranges.Source: fortiguard.fortinet.com

What should I do about it?

Upgrade FortiOS to 7.0.17 or above. The checked facts do not give a fixed FortiProxy version.Source: fortiguard.fortinet.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-01-14, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data

What if there's no patch?

Disable the HTTP/HTTPS administrative interface, which is the listed workaround while no fix is installed.Source: fortiguard.fortinet.com