upgrademysqlstatus in databases/views.py in CyberPanel (aka Cyber Panel) before 5b08cd6 allows remote attackers to bypass authentication and
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
CyberPanel, a web hosting control panel, is affected. A remote attacker could bypass login and run arbitrary system commands on the server through its database upgrade status feature.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
upgrademysqlstatus in databases/views.py in CyberPanel (aka Cyber Panel) before 5b08cd6 allows remote attackers to bypass authentication and execute arbitrary commands via /dataBases/upgrademysqlstatus by bypassing secMiddleware (which is only for a POST request) and using shell metacharacters in the statusfile property, as exploited in the wild in October 2024 by PSAUX. Versions through 2.3.6 and (unpatched) 2.3.7 are affected.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- n/a n/a
Version range not reported
References 7
cwe.mitre.org
GitHub · usmannasir/cyberpanel
cyberpanel.net
Questions about CVE-2024-51567
What does this mean?
The upgrademysqlstatus endpoint in CyberPanel's databases/views.py had no authentication check, so a remote user without a login could pass shell metacharacters in the statusfile property. The advisory says this can run operating system commands as root.Source: dreyand.rs, github.com
Am I affected, and how do I check?
The affected versions are CyberPanel through 2.3.6 and the unpatched 2.3.7, per the researcher's testing on the latest release. To check a installation, compare its CyberPanel version against that range.Source: dreyand.rs, github.com
What should I do about it?
Update to a build that includes commit 5b08cd6, which added the missing authentication check. The facts do not name a released version that contains this commit.Source: dreyand.rs, github.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2024-11-07, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data
What if there's no patch?
No workaround is documented in the available facts. The only listed change is commit 5b08cd6, which adds the authentication check.Source: dreyand.rs, github.com