In Cleo Harmony before 5.8.0.21, VLTrader before 5.8.0.21, and LexiCom before 5.8.0.21, there is an unrestricted file upload and download th
Affects Cleo Harmony, VLTrader, and LexiCom before 5.8.0.21. The facts give no vendor rating, only the CVSS score of 9.8 (critical). Fixed in 5.8.0.21.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 5.8.0.21
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: active
- Automatable: no
- Technical impact: total
Summary
Cleo Harmony, VLTrader, and LexiCom, which are file transfer and managed data exchange products, are affected by this vulnerability. An attacker could abuse unrestricted file upload and download functionality to potentially run malicious code remotely on the affected system.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
In Cleo Harmony before 5.8.0.21, VLTrader before 5.8.0.21, and LexiCom before 5.8.0.21, there is an unrestricted file upload and download that could lead to remote code execution.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- CISA SSVC assessment
Exploitation: active · Automatable: no · Technical impact: total
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
No affected packages have been listed by the sources.
References 1
support.cleo.com
Questions about CVE-2024-50623
What does this mean?
The flaw lets a user upload and download files without the restrictions that should apply, and this could lead to remote code execution on the affected server.Source: support.cleo.com
Am I affected, and how do I check?
Cleo Harmony, VLTrader, and LexiCom versions before 5.8.0.21 are affected. To check a deployment, look up the installed product version in the application's version information and compare it with 5.8.0.21.Source: support.cleo.com
What should I do about it?
Upgrade Harmony, VLTrader, and LexiCom instances to the latest released patch, version 5.8.0.21.Source: support.cleo.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2024-12-13, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data