Skip to main content
← All vulnerabilities
CVE-2024-50603

An issue was discovered in Aviatrix Controller before 7.1.4191 and 7.2.x before 7.2.4996.

Affects Aviatrix Controller before 7.1.4191 and 7.2.x before 7.2.4996. CVSS scores it 10 (critical); no vendor rating is given. Fixed in 7.1.4191 and 7.2.4996.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 7.1.4191, 7.2.4996
None on Exploit-DB, Metasploit or GitHub

Summary

The Aviatrix Controller, a cloud network management product, is affected by this vulnerability. An unauthenticated attacker could send specially crafted input to its API and run arbitrary commands on the underlying system.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

An issue was discovered in Aviatrix Controller before 7.1.4191 and 7.2.x before 7.2.4996. Due to the improper neutralization of special elements used in an OS command, an unauthenticated attacker is able to execute arbitrary code. Shell metacharacters can be sent to /v1/api in cloud_type for list_flightpath_destination_instances, or src_cloud_type for flightpath_connection_test.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Aviatrix Controller

    fixed in 7.1.4191; From 7.2.0 · fixed in 7.2.4996

References 3

docs.aviatrix.com

securing.pl

FAQ

Questions about CVE-2024-50603

What does this mean?

The flaw lets an unauthenticated party run arbitrary operating system commands on the controller. The request must include a CID value, but the CID is not validated before the command runs, so any value works.Source: securing.pl

Am I affected, and how do I check?

The sources describe Aviatrix Controller 7.x through 7.2.4820, and the fixed-version ranges cover versions before 7.1.4191 and 7.2.0 through versions before 7.2.4996. Compare the controller's installed version against these ranges.Source: securing.pl

What should I do about it?

Upgrade to 7.1.4191 or later on the 7.1 line, or to 7.2.4996 or later on the 7.2 line.Source: securing.pl

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-01-16, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data