A Cross-Site Scripting vulnerability in Roundcube through 1.5.7 and 1.6.x through 1.6.7 allows a remote attacker to steal and send emails of
Roundcube 1.5.7 and below, and 1.6.x through 1.6.7, are affected. The vendor's advisory gives no separate rating beyond CVSS. Fixed in 1.5.8 and 1.6.8.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 1.5.8, 1.6.8
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Roundcube, an open-source webmail application, is affected by this flaw. A remote attacker could send a specially crafted email that runs malicious scripts in a victim's browser, allowing the attacker to read and send emails from the victim's account.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
A Cross-Site Scripting vulnerability in Roundcube through 1.5.7 and 1.6.x through 1.6.7 allows a remote attacker to steal and send emails of a victim via a crafted e-mail message that abuses a Desanitization issue in message_body() in program/actions/mail/show.php.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- n/a n/a
Version range not reported
References 5
GitHub · roundcube/roundcubemail
sonarsource.com
roundcube.net
Questions about CVE-2024-42009
What does this mean?
This is a Cross-Site Scripting flaw in the Roundcube webmail software. The advisory says an unauthenticated remote attacker can steal emails and contacts, and send emails from a victim's account.Source: sonarsource.com
Am I affected, and how do I check?
Roundcube 1.5.7 and below, and 1.6.x through 1.6.7, are listed as vulnerable. To check, compare the installed Roundcube version against these ranges.Source: sonarsource.com
What should I do about it?
Roundcube administrators should update to the patched version 1.6.8 or 1.5.8 as soon as possible.Source: sonarsource.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-06-09, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data