Privilege escalation vulnerability
Affects VMware vCenter Server 8.0 before 8.0 U3b and 7.0 before 7.0 U3s, on any platform. The fix is in 8.0 U3b and 7.0 U3s. No vendor severity rating is given.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 8.0 U3b, 7.0 U3s
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The vCenter Server, VMware's software for managing virtualized computing environments, is affected by this vulnerability. An attacker with network access to the server could send a specially crafted network packet to gain root-level privileges, giving them full control over the system.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
The vCenter Server contains a privilege escalation vulnerability. A malicious actor with network access to vCenter Server may trigger this vulnerability to escalate privileges to root by sending a specially crafted network packet.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- n/a VMware vCenter Server
From 8.0 · fixed in 8.0 U3b; From 7.0 · fixed in 7.0 U3s
- n/a VMware Cloud Foundation
5.x, 4.x
References 1
Questions about CVE-2024-38813
What does this mean?
An attacker can escalate privileges to root on vCenter Server by sending a specially crafted network packet. The flaw lets a party without root access gain root control of the server.Source: support.broadcom.com
Am I affected, and how do I check?
VMware vCenter Server 8.0 before 8.0 U3b and 7.0 before 7.0 U3s are listed as affected, on any platform per the vendor's response matrix. VMware Cloud Foundation 4.x, 5.x and 5.1.x are also named in the affected conditions. To check a vCenter Server version, compare the build shown in the vSphere Client or the appliance's version output against the listed fixed versions.Source: support.broadcom.com
What should I do about it?
Upgrade vCenter Server to 8.0 U3b or 7.0 U3s, the fixed versions listed for each release line.Source: support.broadcom.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2024-11-20, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data