Skip to main content
← All vulnerabilities
CVE-2024-38812

Heap-overflow vulnerability

VMware vCenter Server 7.0 before 7.0 U3s and 8.0 before 8.0 U3b are affected, and VMware Cloud Foundation is also listed. Fixed in vCenter 7.0 U3s and 8.0 U3b.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 8.0 U3b, 7.0 U3s
None on Exploit-DB, Metasploit or GitHub

Summary

The affected software is VMware vCenter Server, a tool used to manage virtualized computing environments. An attacker who can reach the server over the network could send a specially crafted packet that exploits a memory flaw in its DCERPC handling, potentially allowing them to run arbitrary code on the system.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

The vCenter Server contains a heap-overflow vulnerability in the implementation of the DCERPC protocol. A malicious actor with network access to vCenter Server may trigger this vulnerability by sending a specially crafted network packet potentially leading to remote code execution.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • n/a VMware vCenter Server

    From 8.0 · fixed in 8.0 U3b; From 7.0 · fixed in 7.0 U3s

  • n/a VMware Cloud Foundation

    5.x, 4.x

References 1

support.broadcom.com

FAQ

Questions about CVE-2024-38812

What does this mean?

This is a heap overflow, meaning memory outside the intended buffer on the heap can be written to. The impact is potentially remote code execution on vCenter Server.Source: support.broadcom.com

Am I affected, and how do I check?

The response matrix lists VMware vCenter Server 8.0 before 8.0 U3b and 7.0 before 7.0 U3s. VMware Cloud Foundation 5.x, 5.1.x and 4.x is also listed, but no fixed version is given for it. To check, compare the installed vCenter Server version against these ranges.Source: support.broadcom.com

What should I do about it?

Upgrade vCenter Server to 8.0 U3b or 7.0 U3s, the fixed versions listed in the facts.Source: support.broadcom.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2024-11-20, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data