vCenter Server contains a heap-overflow vulnerability in the implementation of the DCERPC protocol.
vCenter Server 8.0 before 8.0 U2d, 8.0 before 8.0 U1e, and 7.0 before 7.0 U3r are affected, as are Cloud Foundation deployments that use vCenter Server. Fixed in 8.0 U2d, 8.0 U1e, and 7.0 U3r.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 8.0 U2d, 8.0 U1e, 7.0 U3r
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
VMware vCenter Server, a platform used to manage virtualized server environments, is affected by this flaw. An attacker with network access could send a specially crafted packet to exploit it, potentially running malicious code remotely on the server.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
vCenter Server contains a heap-overflow vulnerability in the implementation of the DCERPC protocol. A malicious actor with network access to vCenter Server may trigger this vulnerability by sending a specially crafted network packet potentially leading to remote code execution.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- Record last updated
- CISA remediation deadline
Due date for US federal agencies to patch
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- n/a VMware vCenter Server
From 8.0 · fixed in 8.0 U2d; From 8.0 · fixed in 8.0 U1e; From 7.0 · fixed in 7.0 U3r
- n/a VMware Cloud Foundation
5.x, 4.x
References 1
Questions about CVE-2024-37079
What does this mean?
The bug is a heap overflow in vCenter Server's implementation of the DCERPC protocol. The facts say it can potentially lead to remote code execution on vCenter Server.Source: support.broadcom.com
Am I affected, and how do I check?
Affected versions are vCenter Server 8.0 before 8.0 U2d, 8.0 before 8.0 U1e, and 7.0 before 7.0 U3r. Cloud Foundation 5.x and 4.x deployments that include vCenter Server are also listed. To check a vCenter Server version, compare the build shown in its version information against these fixed releases.Source: support.broadcom.com
What should I do about it?
Upgrade vCenter Server to the fixed release for your release line: 8.0 U2d, 8.0 U1e, or 7.0 U3r.Source: support.broadcom.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-01-23, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data