XXE can expose crypt key and other secrets granting full admin access
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 2.4.6-p6, 2.4.5-p8, 2.4.4-p9
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Adobe Commerce, an ecommerce platform, is affected by this vulnerability, which involves improper handling of XML external entity references. Successful exploitation could allow an attacker to execute arbitrary code on the affected system.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Adobe Commerce versions 2.4.7, 2.4.6-p5, 2.4.5-p7, 2.4.4-p8 and earlier are affected by an Improper Restriction of XML External Entity Reference ('XXE') vulnerability that could result in arbitrary code execution. An attacker could exploit this vulnerability by sending a crafted XML document that references external entities. Exploitation of this issue does not require user interaction.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- Adobe Adobe Commerce
through 2.4.4-p8
- magento/community-editionPackagist
2.4.4
- magento/community-editionPackagist
From 2.4.6-p1 · fixed in 2.4.6-p6
- magento/community-editionPackagist
From 2.4.5-p1 · fixed in 2.4.5-p8
- magento/community-editionPackagist
fixed in 2.4.4-p9
- magento/community-editionPackagist
2.4.5
- magento/community-editionPackagist
2.4.6
- magento/community-editionPackagist
2.4.7
References 2
Questions about CVE-2024-34102
What does this mean?
The bug is an XML external entity (XXE) flaw, which lets crafted XML make the software read data it should not reach. Per the title, this can expose the crypt key and other secrets, which can lead to full admin access. The listed impact also cites arbitrary code execution via nested deserialization, with potential data breaches and system compromise.Source: vicarius.io
Am I affected, and how do I check?
The conditions say Adobe Commerce and Magento versions 2.4.6 and earlier are affected. The product data lists Adobe Commerce up to 2.4.4-p8, magento/community-edition from 0 up to but not including 2.4.4-p9, from 2.4.5-p1 to before 2.4.5-p8, and from 2.4.6-p1 to before 2.4.6-p6. To check your installation, look at your installed Magento or Adobe Commerce version, for example with bin/magento --version.Source: vicarius.io
What should I do about it?
Upgrade to a fixed release for your line: 2.4.4-p9 or later for 2.4.4, 2.4.5-p8 or later for 2.4.5, or 2.4.6-p6 or later for 2.4.6. The facts do not give a confirmed fixed version for Adobe Commerce, so check Adobe's advisory for its patch.Source: vicarius.io
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2024-07-17, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data