Jenkins 2.441 and earlier, LTS 2.426.2 and earlier does not disable a feature of its CLI command parser that replaces an '@' character follo
Jenkins 2.441 and earlier, and LTS 2.426.2 and earlier, are affected when the CLI expandAtFiles feature is enabled, which it is by default. Fixed in Jenkins 2.442, LTS 2.426.3, and LTS 2.440.1.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 2.426.3, 2.440.1, 2.442
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Jenkins, an open-source automation server, is affected through its command-line interface (CLI) command parser. The flaw allows unauthenticated attackers to read arbitrary files from the Jenkins controller's file system, which could expose sensitive data such as credentials and configuration secrets.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Jenkins 2.441 and earlier, LTS 2.426.2 and earlier does not disable a feature of its CLI command parser that replaces an '@' character followed by a file path in an argument with the file's contents, allowing unauthenticated attackers to read arbitrary files on the Jenkins controller file system.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- Jenkins Project Jenkins
Version range not reported
- org.jenkins-ci.main:jenkins-coreMaven
From 1.606 · fixed in 2.426.3
- org.jenkins-ci.main:jenkins-coreMaven
From 2.427 · fixed in 2.440.1
- org.jenkins-ci.main:jenkins-coreMaven
From 2.441 · fixed in 2.442
References 5
openwall.com
Questions about CVE-2024-23897
What does this mean?
The Jenkins CLI command parser replaces an @ character followed by a file path in an argument with that file's contents. This lets attackers read arbitrary files on the Jenkins controller file system. Attackers with Overall/Read permission can read entire files, and attackers without it can read the first few lines of files.Source: jenkins.io
Am I affected, and how do I check?
Jenkins 2.441 and earlier, and LTS 2.426.2 and earlier, are affected, as is any setup where the CLI expandAtFiles feature is enabled, which it is by default. To check, compare the installed Jenkins version with these releases and check whether the CLI expandAtFiles feature is enabled.Source: jenkins.io
What should I do about it?
Upgrade to Jenkins 2.442, LTS 2.426.3, or LTS 2.440.1, which disable the command parser feature that replaces @ followed by a file path. If you cannot upgrade, the advisory's workaround is to disable access to the CLI.Source: jenkins.io
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2024-08-19, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data