Skip to main content
← All vulnerabilities
CVE-2024-21762

A out-of-bounds write vulnerability in Fortinet FortiOS 7.4.0 through 7.4.2, FortiOS 7.2.0 through 7.2.6, FortiOS 7.0.0 through 7.0.13, Fort

Published
Last modified
published
Listed in CISA KEV
Actively exploited
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: active
  • Automatable: yes
  • Technical impact: total

Summary

The vulnerability affects Fortinet FortiOS and FortiProxy, network security products used to protect and manage enterprise networks. An attacker could exploit it by sending specially crafted requests to run unauthorized code or commands on the affected device.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

A out-of-bounds write vulnerability in Fortinet FortiOS 7.4.0 through 7.4.2, FortiOS 7.2.0 through 7.2.6, FortiOS 7.0.0 through 7.0.13, FortiOS 6.4.0 through 6.4.14, FortiOS 6.2.0 through 6.2.15, FortiOS 6.0 all versions, FortiProxy 7.4.0 through 7.4.2, FortiProxy 7.2.0 through 7.2.8, FortiProxy 7.0.0 through 7.0.14, FortiProxy 2.0.0 through 2.0.13, FortiProxy 01.02 all versions, FortiProxy 1.2 all versions, FortiProxy 01.01 all versions, FortiProxy 1.1 all versions, FortiProxy 01.00 all versions allows attacker to execute unauthorized code or commands via specifically crafted requests

Timeline

  1. CISA SSVC assessment

    Exploitation: active · Automatable: yes · Technical impact: total

  2. CVE published
  3. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  4. CISA remediation deadline

    Due date for US federal agencies to patch

  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

  6. Record last updated

Affected versions

  • Fortinet FortiOS

    From 7.4.0 · through 7.4.2; From 7.2.0 · through 7.2.6; From 7.0.0 · through 7.0.13; From 6.4.0 · through 6.4.14; From 6.2.0 · through 6.2.15; From 6.0.0 · through 6.0.18

  • Fortinet FortiProxy

    From 7.4.0 · through 7.4.2; From 7.2.0 · through 7.2.8; From 7.0.0 · through 7.0.14; From 2.0.0 · through 2.0.13; From 1.2.1 · through 1.2.13; From 1.1.4 · through 1.1.6; From 01.01.00 · through 01.01.03; From 01.00.00 · through 01.00.07

References 1

fortiguard.com

FAQ

Questions about CVE-2024-21762

What does this mean?

An out-of-bounds write flaw (CWE-787) in FortiOS and FortiProxy may allow specially crafted HTTP requests to execute arbitrary code or commands on the affected device.Source: fortiguard.com

Am I affected, and how do I check?

FortiOS 7.4.0 through 7.4.2, 7.2.0 through 7.2.6, 7.0.0 through 7.0.13, 6.4.0 through 6.4.14, 6.2.0 through 6.2.15, and 6.0.0 through 6.0.18 are listed. FortiProxy 7.4.0 through 7.4.2, 7.2.0 through 7.2.8, 7.0.0 through 7.0.14, 2.0.0 through 2.0.13, 1.2.1 through 1.2.13, 1.1.4 through 1.1.6, 01.01.00 through 01.01.03, and 01.00.00 through 01.00.07 are listed. The advisory's workaround applies when SSL VPN is enabled, so check the firmware version and whether SSL VPN is turned on in the device settings.Source: fortiguard.com

What should I do about it?

The advisory's stated fix is to upgrade to 7.4.3 or above.Source: fortiguard.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2024-02-09, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data

What if there's no patch?

Disable SSL VPN, which is the workaround the advisory gives while no fix is installed.Source: fortiguard.com