Skip to main content
← All vulnerabilities
CVE-2024-1086

Use-after-free in Linux kernel's netfilter: nf_tables component

Linux kernel versions from 3.15 up to 6.8 are affected in builds that include commit e0abdadcc6e1, which nf_tables netfilter code relies on. The fix is listed as version 6.8.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 6.8
None on Exploit-DB, Metasploit or GitHub

Summary

The Linux kernel's netfilter nf_tables component is affected, which is used for packet filtering and firewall rules on Linux systems. A local attacker with access to the system could exploit this memory-handling flaw to gain elevated (root-level) privileges.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

A use-after-free vulnerability in the Linux kernel's netfilter: nf_tables component can be exploited to achieve local privilege escalation. The nft_verdict_init() function allows positive values as drop error within the hook verdict, and hence the nf_hook_slow() function can cause a double free vulnerability when NF_DROP is issued with a drop error which resembles NF_ACCEPT. We recommend upgrading past commit f342de4e2f33e0e39165d8639387aa6c19dff660.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • kernel

    From 3.15 · fixed in 6.8

References 14

git.kernel.org

kernel.dance

lists.fedoraproject.org

GitHub · Notselwyn/CVE-2024-1086

news.ycombinator.com

pwning.tech

openwall.com

security.netapp.com

lists.debian.org

FAQ

Questions about CVE-2024-1086

What does this mean?

A use-after-free bug in the netfilter nf_tables component lets the kernel use memory after it has been freed. It happens in nf_hook_slow when nf_tables accepts a positive value as a drop verdict parameter, and it can lead to local privilege escalation.Source: git.kernel.org

Am I affected, and how do I check?

Linux kernel versions from 3.15 up to, but not including, 6.8 are listed as affected. Builds that include commit e0abdadcc6e1 are the ones described, since this fix reverts that commit; check the kernel version with uname -r and compare it against the range.Source: git.kernel.org

What should I do about it?

Upgrade the Linux kernel to version 6.8 or later, which the listed fixed version. Use your distribution's kernel update to get a build that includes the revert.Source: git.kernel.org

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2024-05-30, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data