Glibc: buffer overflow in ld.so leading to privilege escalation
Affects glibc 2.34 through 2.38 and several Red Hat Enterprise Linux releases. Red Hat lists glibc 2.34-28.el9_0.4 as the fix. No vendor rating is given.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 2.39
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 on Exploit-DB
- Exploitation: active
- Automatable: no
- Technical impact: total
Summary
The GNU C Library (glibc), specifically its dynamic loader ld.so, is affected. A local attacker could abuse a specially crafted GLIBC_TUNABLES environment variable when launching SUID binaries to run code with elevated privileges.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
A buffer overflow was discovered in the GNU C Library's dynamic loader ld.so while processing the GLIBC_TUNABLES environment variable. This issue could allow a local attacker to use maliciously crafted GLIBC_TUNABLES environment variables when launching binaries with SUID permission to execute code with elevated privileges.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- CISA SSVC assessment
Exploitation: active · Automatable: no · Technical impact: total
- Public exploit on Exploit-DB
EDB-52479
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- glibc
From 2.34 · fixed in 2.39
- glibc
Version range not reported
- glibc
Version range not reported
- glibc
Version range not reported
- glibc
Version range not reported
- glibc
Version range not reported
- redhat-release-virtualization-host
Version range not reported
- redhat-virtualization-host
Version range not reported
- glibc
Version range not reported
- compat-glibc
Version range not reported
- glibc
Version range not reported
References 10
access.redhat.com
bugzilla.redhat.com
qualys.com
Exploit-DB
Questions about CVE-2023-4911
What does this mean?
A buffer overflow in ld.so, the glibc dynamic loader, can lead to elevated privileges. The flaw is a memory-safety bug in how the loader handles data.Source: access.redhat.com
Am I affected, and how do I check?
Upstream glibc versions from 2.34 up to but not including 2.39 are listed as affected, along with several Red Hat Enterprise Linux releases and related Red Hat products. To check a system, run ldd --version to see its glibc version and compare it with the listed range and the vendor's package versions.Source: access.redhat.com
What should I do about it?
Update glibc to a fixed build: the Red Hat fix is glibc 2.34-28.el9_0.4 for Red Hat Enterprise Linux 9.0, and upstream glibc 2.39 or later contains the fix. Apply the update through your distribution's package manager.Source: access.redhat.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2023-11-21, which means it has evidence of attacks. Public exploit code exists (Exploit-DB).Source: cisa.gov, cve.now feed data