Skip to main content
← All vulnerabilities
CVE-2023-48788

A improper neutralization of special elements used in an sql command ('sql injection') in Fortinet FortiClientEMS version 7.2.0 through 7.2.

FortiClientEMS 7.2.0 through 7.2.2 and 7.0.1 through 7.0.10 are affected. The fix is in 7.2.3 or above, and the facts give no fixed version for the 7.0 branch.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 7.2.3
None on Exploit-DB, Metasploit or GitHub

Summary

Fortinet FortiClientEMS, an endpoint management server used to control FortiClient deployments, is affected by this SQL injection flaw. An attacker who sends specially crafted requests could run unauthorized code or commands on the affected server.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

A improper neutralization of special elements used in an sql command ('sql injection') in Fortinet FortiClientEMS version 7.2.0 through 7.2.2, FortiClientEMS 7.0.1 through 7.0.10 allows attacker to execute unauthorized code or commands via specially crafted packets.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Fortinet FortiClientEMS

    From 7.2.0 · through 7.2.2; From 7.0.1 · through 7.0.10

References 1

fortiguard.com

FAQ

Questions about CVE-2023-48788

What does this mean?

The product does not properly neutralize special characters in input used in SQL commands, which is a SQL injection flaw. The advisory says it may allow an unauthenticated attacker to execute unauthorized code or commands on FortiClientEMS.Source: fortiguard.com

Am I affected, and how do I check?

FortiClientEMS 7.2.0 through 7.2.2 and 7.0.1 through 7.0.10 are listed as affected. To check a installed version, look at the FortiClientEMS version shown in its admin console or product information.Source: fortiguard.com

What should I do about it?

Upgrade to FortiClientEMS 7.2.3 or above, as the advisory directs. The facts list no fixed version or workaround for the 7.0 branch.Source: fortiguard.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2024-03-25, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data