Skip to main content
← All vulnerabilities
CVE-2023-4762

Type Confusion in V8 in Google Chrome prior to 116.0.5845.179 allowed a remote attacker to execute arbitrary code via a crafted HTML page.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 116.0.5845.179
None on Exploit-DB, Metasploit or GitHub

Summary

The vulnerability affects Google Chrome, specifically its V8 JavaScript engine, in releases before the fixed version. A remote attacker could exploit it by luring a user to a specially crafted HTML page, potentially running arbitrary code on the affected computer.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Type Confusion in V8 in Google Chrome prior to 116.0.5845.179 allowed a remote attacker to execute arbitrary code via a crafted HTML page. (Chromium security severity: High)

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Google Chrome

    From 116.0.5845.179 · fixed in 116.0.5845.179

References 10

chromereleases.googleblog.com

crbug.com

debian.org

lists.fedoraproject.org

security.gentoo.org

msrc.microsoft.com

FAQ

Questions about CVE-2023-4762

What does this mean?

The bug is a type confusion in V8, Chrome's JavaScript engine, where code treats a value as a different type than it really is. The advisory says a crafted HTML page could lead to arbitrary code execution, denial of service or information disclosure.Source: lists.debian.org

Am I affected, and how do I check?

The advisory covers Google Chrome prior to 116.0.5845.179. To check the installed version, open chrome://version or the About page in the Help menu. The Debian package fix is listed for version 116.0.5845.180-1~deb11u1.Source: lists.debian.org

What should I do about it?

Update Chrome to version 116.0.5845.180 or later. On Debian, install 116.0.5845.180-1~deb11u1 or a later build.Source: lists.debian.org

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2024-02-06, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data