Apache ActiveMQ, Apache ActiveMQ Legacy OpenWire Module: Unbounded deserialization causes ActiveMQ to be vulnerable to a remote code execution (RCE) attack
Java-based Apache ActiveMQ brokers and clients using the OpenWire protocol marshaller are affected in older releases up to 5.18.2. Fixed in 5.15.16, 5.16.7, 5.17.6, and 5.18.3.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 5.18.3, 5.17.6, 5.16.7, 5.15.16
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Apache ActiveMQ and the ActiveMQ Legacy OpenWire module, including Java-based OpenWire brokers and clients, are affected. A remote attacker with network access could run arbitrary shell commands on the affected broker or client by manipulating serialized class types, potentially taking full control of the system.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
The Java OpenWire protocol marshaller is vulnerable to Remote Code Execution. This vulnerability may allow a remote attacker with network access to either a Java-based OpenWire broker or client to run arbitrary shell commands by manipulating serialized class types in the OpenWire protocol to cause either the client or the broker (respectively) to instantiate any class on the classpath. Users are recommended to upgrade both brokers and clients to version 5.15.16, 5.16.7, 5.17.6, or 5.18.3 which fixes this issue.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- org.apache.activemq:activemq-client
From 5.18.0 · fixed in 5.18.3; From 5.17.0 · fixed in 5.17.6; From 5.16.0 · fixed in 5.16.7; fixed in 5.15.16
- org.apache.activemq:activemq-openwire-legacy
From 5.18.0 · fixed in 5.18.3; From 5.17.0 · fixed in 5.17.6; From 5.16.0 · fixed in 5.16.7; From 5.8.0 · fixed in 5.15.16
- org.apache.activemq:activemq-clientMaven
fixed in 5.15.16
- org.apache.activemq:activemq-clientMaven
From 5.16.0 · fixed in 5.16.7
- org.apache.activemq:activemq-clientMaven
From 5.17.0 · fixed in 5.17.6
- org.apache.activemq:activemq-clientMaven
From 5.18.0 · fixed in 5.18.3
- org.apache.activemq:activemq-openwire-legacyMaven
From 5.8.0 · fixed in 5.15.16
- org.apache.activemq:activemq-openwire-legacyMaven
From 5.16.0 · fixed in 5.16.7
- org.apache.activemq:activemq-openwire-legacyMaven
From 5.17.0 · fixed in 5.17.6
- org.apache.activemq:activemq-openwire-legacyMaven
From 5.18.0 · fixed in 5.18.3
References 6
activemq.apache.org
openwall.com
security.netapp.com
packetstormsecurity.com
lists.debian.org
seclists.org
Questions about CVE-2023-46604
What does this mean?
The Java OpenWire protocol marshaller can be made to run arbitrary shell commands by manipulating serialized class types, so the broker or client instantiates any class on its classpath.Source: activemq.apache.org
Am I affected, and how do I check?
Java-based OpenWire brokers or clients using the Java OpenWire protocol marshaller are in scope. Affected ranges are 5.18.0 before 5.18.3, 5.17.0 before 5.17.6, 5.16.0 before 5.16.7, and anything before 5.15.16 (Legacy OpenWire Module 5.8.0 before 5.15.16). To check, look at the ActiveMQ version in use or the activemq-client and activemq-openwire-legacy artifact versions in the project dependencies.Source: activemq.apache.org
What should I do about it?
Upgrade both brokers and clients to 5.15.16, 5.16.7, 5.17.6, or 5.18.3, using the fixed version on the same release line. The advisory says this upgrade fixes the issue and gives no workaround.Source: activemq.apache.org
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2023-11-02, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data