Proself Enterprise/Standard Edition Ver5.62 and earlier, Proself Gateway Edition Ver1.65 and earlier, and Proself Mail Sanitize Edition Ver1
Proself Enterprise/Standard Ver5.62 and earlier, Gateway Edition Ver1.65 and earlier, and Mail Sanitize Edition Ver1.08 and earlier are affected. The fix is in Proself Ver5.63.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in Proself Ver5.63
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Proself Enterprise/Standard Edition, Proself Gateway Edition, and Proself Mail Sanitize Edition are affected. A remote attacker without logging in could read arbitrary files on the server, including files containing account information, by sending a specially crafted request.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Proself Enterprise/Standard Edition Ver5.62 and earlier, Proself Gateway Edition Ver1.65 and earlier, and Proself Mail Sanitize Edition Ver1.08 and earlier allow a remote unauthenticated attacker to conduct XML External Entity (XXE) attacks. By processing a specially crafted request containing malformed XML data, arbitrary files on the server containing account information may be read by the attacker.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
Affected versions
- North Grid Corporation Proself Enterprise/Standard Edition
Ver5.62 and earlier
- North Grid Corporation Proself Gateway Edition
Ver1.65 and earlier
- North Grid Corporation Proself Mail Sanitize Edition
Ver1.08 and earlier
References 2
proself.jp
jvn.jp
Questions about CVE-2023-45727
What does this mean?
An attacker can read arbitrary files on the server, such as account information.Source: jvn.jp, proself.jp
Am I affected, and how do I check?
Affected versions are Proself Enterprise/Standard Edition Ver5.62 and earlier, Proself Gateway Edition Ver1.65 and earlier, and Proself Mail Sanitize Edition Ver1.08 and earlier. Compare the Proself version and edition you run against this list.Source: jvn.jp, proself.jp
What should I do about it?
Update to Proself Ver5.63, which the vendor released on 2023/10/17 with the fix. If you cannot update yet, apply the workaround of overwriting the updaterafterreboot.xml file into the Proself WEB-INF/xml/process/admin/config folder.Source: jvn.jp, proself.jp
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2024-12-03, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data