NextGen Healthcare Mirth Connect before version 4.4.1 is vulnerable to unauthenticated remote code execution.
Affects NextGen Healthcare Mirth Connect versions before 4.4.1, with a CVSS score of 9.8 (critical). Fixed in 4.4.1.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 4.4.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
NextGen Healthcare Mirth Connect, an integration engine used to move data between healthcare systems, is affected by this flaw. An attacker without any login credentials could remotely run arbitrary code on the affected server, potentially taking control of it and the healthcare data it processes.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
NextGen Healthcare Mirth Connect before version 4.4.1 is vulnerable to unauthenticated remote code execution. Note that this vulnerability is caused by the incomplete patch of CVE-2023-37679.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- n/a n/a
Version range not reported
References 2
packetstormsecurity.com
Questions about CVE-2023-43208
What does this mean?
The bug allows unauthenticated remote code execution on the Mirth Connect server, so code can run there without logging in. On Windows, where the server typically runs as the SYSTEM user, this gives high-privilege control of the host and access to sensitive healthcare data.Source: horizon3.ai
Am I affected, and how do I check?
Mirth Connect versions prior to 4.4.1 are affected. Check the Mirth Connect version installed on the server to see where it falls relative to 4.4.1.Source: horizon3.ai
What should I do about it?
Upgrade Mirth Connect to 4.4.1, which contains the fix for CVE-2023-43208.Source: horizon3.ai
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2024-05-20, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data