The issue was addressed with improved checks.
Affects WebKitGTK before 2.42.2 (net-libs/webkit-gtk on all architectures). Fixed in 2.42.2. No known workaround is listed.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 14
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Apple's macOS Sonoma and iOS software contain a flaw in how they process web content. An attacker could potentially use this flaw to run arbitrary code on an affected device.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
The issue was addressed with improved checks. This issue is fixed in macOS Sonoma 14. Processing web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited against versions of iOS before iOS 16.7.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- Apple macOS
From unspecified · fixed in 14
References 3
support.apple.com
security.gentoo.org
security.netapp.com
Questions about CVE-2023-41993
What does this mean?
The sources only say the issue was addressed with improved checks. They do not describe what the bug does in plain words.Source: security.gentoo.org
Am I affected, and how do I check?
WebKitGTK versions before 2.42.2 are affected, including the net-libs/webkit-gtk package on all architectures. To check, compare the installed net-libs/webkit-gtk version with 2.42.2 using your package manager, for example with emerge.Source: security.gentoo.org
What should I do about it?
Upgrade net-libs/webkit-gtk to 2.42.2 or later. The sources give this command: emerge --ask --oneshot --verbose ">=net-libs/webkit-gtk-2.42.2".Source: security.gentoo.org
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2023-09-25, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data