Skip to main content
← All vulnerabilities
CVE-2023-34048

VMware vCenter Server Out-of-Bounds Write Vulnerability

Affects VMware vCenter Server 8.0 before 8.0U2 and 7.0 before 7.0U3o, plus VMware Cloud Foundation builds that include vCenter Server. Fixed in 8.0U2 and 7.0U3o.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 8.0U2, 7.0U3o
None on Exploit-DB, Metasploit or GitHub

Summary

VMware vCenter Server, the management platform used to control VMware virtual infrastructure, is affected. An attacker with network access to the server could exploit a memory flaw in its DCERPC protocol handling to potentially run malicious code remotely.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

vCenter Server contains an out-of-bounds write vulnerability in the implementation of the DCERPC protocol. A malicious actor with network access to vCenter Server may trigger an out-of-bounds write potentially leading to remote code execution.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • VMware VMware vCenter Server

    From 8.0 · fixed in 8.0U2; From 7.0 · fixed in 7.0U3o

  • VMware VMware Cloud Foundation (VMware vCenter Server)

    5.x, 4.x

References 1

vmware.com

FAQ

Questions about CVE-2023-34048

What does this mean?

The bug is an out-of-bounds write in the DCERPC protocol implementation of vCenter Server. Writing past the end of a memory buffer can potentially lead to remote code execution.Source: support.broadcom.com

Am I affected, and how do I check?

VMware vCenter Server 8.0 before 8.0U2 and 7.0 before 7.0U3o are listed, along with VMware Cloud Foundation builds that include vCenter Server (the advisory's response matrix covers 8.0, 7.0, and VCF 5.x/4.x). Compare the vCenter Server version shown in the vSphere Client or the appliance version output against these ranges.Source: support.broadcom.com

What should I do about it?

Upgrade vCenter Server 8.0 to 8.0U2 or later, or 7.0 to 7.0U3o or later. The checked facts do not list fixed builds for VMware Cloud Foundation, so use the fixed builds in the advisory's response matrix.Source: support.broadcom.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2024-01-22, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data