A memory corruption issue was addressed with improved state management.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 13.3, 15.7, 16.4
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Apple macOS, Safari, iOS, and iPadOS contain a memory corruption flaw. When these products process web content, an attacker may be able to run arbitrary code on the affected device.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
A memory corruption issue was addressed with improved state management. This issue is fixed in macOS Ventura 13.3, Safari 16.4, iOS 16.4 and iPadOS 16.4, iOS 15.7.7 and iPadOS 15.7.7. Processing web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited against versions of iOS released before iOS 15.7.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- Apple macOS
From unspecified · fixed in 13.3
- Apple iOS and iPadOS
From unspecified · fixed in 15.7
- Apple Safari
From unspecified · fixed in 16.4
- Apple iOS and iPadOS
From unspecified · fixed in 16.4
References 4
support.apple.com
Questions about CVE-2023-32435
What does this mean?
A memory corruption flaw in WebKit, the browser engine used by Safari and other Apple apps, can be triggered when web content is processed. The advisory says this may lead to arbitrary code execution.Source: support.apple.com, support.apple.com
Am I affected, and how do I check?
The advisory lists iOS 15.7.7 and iPadOS 15.7.7 on iPhone 6s, iPhone 7, iPhone SE (1st generation), iPad Air 2, iPad mini (4th generation), and iPod touch (7th generation), and Safari 16.4 on macOS Big Sur and macOS Monterey. To check a device, compare its version under Settings > General > About (iOS and iPadOS) or the Apple menu > About This Mac (macOS), and check Safari's version in Safari > About Safari.Source: support.apple.com, support.apple.com
What should I do about it?
Update to macOS 13.3, iOS and iPadOS 16.4, or Safari 16.4 where those are available, or to iOS 15.7.7 or iPadOS 15.7.7 on the older devices listed. The advisory does not give a workaround.Source: support.apple.com, support.apple.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2023-06-23, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data