Remote Code injection in Barracuda Email Security Gateway
Affects Barracuda Email Security Gateway appliances in the range 5.1.3.001 to 9.2.0.006, which is the fixed version. CVSS rates it critical.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 9.2.0.006
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The Barracuda Email Security Gateway appliance is affected. A remote attacker who submits a specially crafted tar archive can execute arbitrary system commands on the device with the gateway's privileges.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
A remote command injection vulnerability exists in the Barracuda Email Security Gateway (appliance form factor only) product effecting versions 5.1.3.001-9.2.0.006. The vulnerability arises out of a failure to comprehensively sanitize the processing of .tar file (tape archives). The vulnerability stems from incomplete input validation of a user-supplied .tar file as it pertains to the names of the files contained within the archive. As a consequence, a remote attacker can specifically format these file names in a particular manner that will result in remotely executing a system command through Perl's qx operator with the privileges of the Email Security Gateway product. This issue was fixed as part of BNSF-36456 patch. This patch was automatically applied to all customer appliances.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- Barracuda Barracuda Email Security Gateway
From 5.1.3.001 · fixed in 9.2.0.006
References 2
barracuda.com
status.barracuda.com
Questions about CVE-2023-2868
What does this mean?
The advisory describes this as remote code injection in the Barracuda Email Security Gateway appliance. Barracuda reports that it resulted in unauthorized access to a subset of email gateway appliances.Source: status.barracuda.com
Am I affected, and how do I check?
The listed affected range is Barracuda Email Security Gateway versions from 5.1.3.001 up to the fixed version 9.2.0.006. To check, compare the installed appliance version against that range.Source: status.barracuda.com
What should I do about it?
Move the appliance to version 9.2.0.006 or later, which is the listed fixed release.Source: status.barracuda.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2023-05-26, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data