Skip to main content
← All vulnerabilities
CVE-2023-27997

A heap-based buffer overflow vulnerability [CWE-122] in FortiOS version 7.2.4 and below, version 7.0.11 and below, version 6.4.12 and below,

Affects the SSL-VPN component of FortiOS 7.2.0-7.2.4, 7.0.0-7.0.11, 6.4.0-6.4.12, 6.2.0-6.2.13 and 6.0.0-6.0.16, and of FortiProxy. Fixed by upgrading FortiOS to 7.2.5 or above.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
None on Exploit-DB, Metasploit or GitHub

Summary

The vulnerability affects Fortinet's FortiOS and FortiProxy operating systems, specifically their SSL-VPN components. A remote attacker could exploit it by sending specially crafted requests, potentially gaining the ability to run arbitrary code or commands on the affected device.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

A heap-based buffer overflow vulnerability [CWE-122] in FortiOS version 7.2.4 and below, version 7.0.11 and below, version 6.4.12 and below, version 6.0.16 and below and FortiProxy version 7.2.3 and below, version 7.0.9 and below, version 2.0.12 and below, version 1.2 all versions, version 1.1 all versions SSL-VPN may allow a remote attacker to execute arbitrary code or commands via specifically crafted requests.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Fortinet FortiOS-6K7K

    From 6.2.9 · through 6.2.13; From 6.2.6 · through 6.2.7; From 6.0.12 · through 6.0.16

  • Fortinet FortiProxy

    From 7.2.0 · through 7.2.3; From 7.0.0 · through 7.0.9; From 2.0.0 · through 2.0.12; From 1.2.0 · through 1.2.13; From 1.1.0 · through 1.1.6

  • Fortinet FortiOS

    From 7.2.0 · through 7.2.4; From 7.0.0 · through 7.0.11; From 6.4.0 · through 6.4.12; From 6.2.0 · through 6.2.13; From 6.0.0 · through 6.0.16

References 1

fortiguard.com

FAQ

Questions about CVE-2023-27997

What does this mean?

The flaw is a heap-based buffer overflow in the SSL-VPN component. A remote attacker may be able to execute arbitrary code or commands by sending specifically crafted requests.Source: fortiguard.com

Am I affected, and how do I check?

FortiOS 7.2.0 through 7.2.4, 7.0.0 through 7.0.11, 6.4.0 through 6.4.12, 6.2.0 through 6.2.13 and 6.0.0 through 6.0.16 are listed as affected, as are FortiProxy 7.2.0 through 7.2.3, 7.0.0 through 7.0.9, 2.0.0 through 2.0.12, and 1.2 and 1.1 all versions. The issue is in SSL-VPN, so check whether SSL-VPN is in use and compare the installed version with these ranges.Source: fortiguard.com

What should I do about it?

Upgrade FortiOS to 7.2.5 or above, as stated in the advisory.Source: fortiguard.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2023-06-13, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data

What if there's no patch?

The workaround given is to disable SSL-VPN until a fixed version can be installed.Source: fortiguard.com