[20230201] - Core - Improper access check in webservice endpoints
Joomla! CMS versions 4.0.0 through 4.2.7 are exposed to an improper access check on webservice endpoints. The fix is in 4.2.8. The facts give no vendor rating.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 4.2.8
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Joomla! content management software, versions 4.0.0 through 4.2.7 (versions omitted here per instructions), is affected by this flaw. An improper access check in its webservice endpoints allows unauthorized users to reach those endpoints, which could expose or let them act on data they should not be able to access.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
An issue was discovered in Joomla! 4.0.0 through 4.2.7. An improper access check allows unauthorized access to webservice endpoints.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- Joomla! Project Joomla! CMS
4.0.0-4.2.7
References 1
Questions about CVE-2023-23752
What does this mean?
An improper access check lets callers reach Joomla! CMS webservice endpoints without authorization.Source: developer.joomla.org
Am I affected, and how do I check?
Joomla! CMS versions 4.0.0 through 4.2.7 are affected. Compare the installed Joomla! CMS version number against that range.Source: developer.joomla.org
What should I do about it?
Upgrade Joomla! CMS to version 4.2.8.Source: developer.joomla.org
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2024-01-08, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data