Skip to main content
← All vulnerabilities
CVE-2023-22894GHSA-JJQF-J4W7-92W8

Strapi through 4.5.5 allows attackers (with access to the admin panel) to discover sensitive user details by exploiting the query filter.

Affects @strapi/strapi from 3.2.1 up to but not including 4.8.0. Fixed in versions later than 4.8.0.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 4.8.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: active
  • Automatable: no
  • Technical impact: total

Summary

Strapi, an open-source content management system, is affected by this vulnerability. An attacker with access to the admin panel could abuse the query filter to infer sensitive user details, such as password hashes and password reset tokens for super admin accounts, or the usernames and emails of API users.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Strapi through 4.5.5 allows attackers (with access to the admin panel) to discover sensitive user details by exploiting the query filter. The attacker can filter users by columns that contain sensitive information and infer a value from API responses. If the attacker has super admin access, then this can be exploited to discover the password hash and password reset token of all users. If the attacker has admin panel access to an account with permission to access the username and email of API users with a lower privileged role (e.g., Editor or Author), then this can be exploited to discover sensitive information for all API users but not other admin accounts.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: active · Automatable: no · Technical impact: total

  3. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  4. Record last updated
  5. CISA remediation deadline

    Due date for US federal agencies to patch

Affected versions

  • @strapi/strapinpm

    From 3.2.1 · fixed in 4.8.0

References 3

GitHub · strapi/strapi

ghostccamm.com

strapi.io

FAQ

Questions about CVE-2023-22894

What does this mean?

Users with access to the admin panel can filter queries on private fields to reveal sensitive user data, such as password hashes and password reset tokens.Source: strapi.io, ghostccamm.com

Am I affected, and how do I check?

Strapi versions from 3.2.1 up to but not including 4.8.0 are affected. The installed @strapi/strapi version can be checked in the project's package.json file.Source: strapi.io, ghostccamm.com

What should I do about it?

Update @strapi/strapi to a version later than 4.8.0. The advisory says to update immediately.Source: strapi.io, ghostccamm.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-10-08, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data