Atlassian has been made aware of an issue reported by a handful of customers where external attackers may have exploited a previously unknow
Confluence Data Center and Server versions 8.0.0 through 8.5.1 are affected when the instance is publicly accessible. Earlier versions are not affected. Fixed in 8.3.3.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 8.3.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Confluence Data Center and Server installations that are publicly accessible on the internet are affected. The flaw could allow an unauthorized party to create administrator accounts and gain access to the Confluence instance.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Atlassian has been made aware of an issue reported by a handful of customers where external attackers may have exploited a previously unknown vulnerability in publicly accessible Confluence Data Center and Server instances to create unauthorized Confluence administrator accounts and access Confluence instances. Atlassian Cloud sites are not affected by this vulnerability. If your Confluence site is accessed via an atlassian.net domain, it is hosted by Atlassian and is not vulnerable to this issue.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- Atlassian Confluence Data Center
From 8.0.0; From 8.0.1; From 8.0.2; From 8.0.3; From 8.1.3; From 8.1.4; From 8.2.0; From 8.2.1; From 8.2.2; From 8.2.3; From 8.3.0; From 8.3.1; From 8.3.2; From 8.4.0; From 8.4.1; From 8.4.2; From 8.5.0; From 8.5.1
- Atlassian Confluence Server
From 8.0.0; From 8.0.1; From 8.0.2; From 8.0.3; From 8.1.3; From 8.1.4; From 8.2.0; From 8.2.1; From 8.2.2; From 8.2.3; From 8.3.0; From 8.3.1; From 8.3.2; From 8.4.0; From 8.4.1; From 8.4.2; From 8.5.0; From 8.5.1
References 4
packetstormsecurity.com
confluence.atlassian.com
jira.atlassian.com
Questions about CVE-2023-22515
What does this mean?
The flaw can let attackers create unauthorized Confluence administrator accounts and access Confluence instances. CVSS scores it 10 (critical).Source: confluence.atlassian.com
Am I affected, and how do I check?
Confluence Data Center and Confluence Server versions 8.0.0 through 8.5.1 are listed as affected, and versions prior to 8.0.0 are not. The advisory also limits the issue to publicly accessible instances, so check the installed version number and whether the instance is reachable from the public internet.Source: confluence.atlassian.com
What should I do about it?
Upgrade to Confluence Data Center or Server 8.3.3 or later. If you cannot upgrade right away, the advisory's workaround is to block access to the /setup/* endpoints at the network layer or with a web.xml security constraint, then restart Confluence.Source: confluence.atlassian.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2023-10-05, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data