An out-of-bounds write issue was addressed with improved bounds checking.
iOS and iPadOS are listed as affected before 16.1 and before 15.7 on the 15.x line. Apple's fix list names 15.7.1. CVSS rates it High (7.8); no vendor severity is given.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 16.1, 15.7
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
This vulnerability affects Apple's iOS and iPadOS operating systems, allowing a malicious application to write data beyond intended memory boundaries. Successful exploitation could let an app run arbitrary code with kernel-level privileges, giving it full control over the device.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
An out-of-bounds write issue was addressed with improved bounds checking. This issue is fixed in iOS 15.7.1 and iPadOS 15.7.1, iOS 16.1 and iPadOS 16. An application may be able to execute arbitrary code with kernel privileges. Apple is aware of a report that this issue may have been actively exploited..
Timeline
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CVE published
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
Affected versions
- Apple iOS and iPadOS
From unspecified · fixed in 16.1
- Apple iOS and iPadOS
From unspecified · fixed in 15.7
References 2
support.apple.com
Questions about CVE-2022-42827
What does this mean?
An out-of-bounds write flaw lets an app execute arbitrary code with kernel privileges. Apple says it was addressed with improved bounds checking.Source: support.apple.com
Am I affected, and how do I check?
The listed affected products are iOS and iPadOS before 16.1, and the 15.x line before 15.7. To check a device, open Settings > General > About and read the iOS or iPadOS version.Source: support.apple.com
What should I do about it?
Update to iOS 16.1 or later, or to iOS 15.7.1 or iPadOS 15.7.1 on the 15.x line.Source: support.apple.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-10-25, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data