Skip to main content
← All vulnerabilities
CVE-2022-42475

A heap-based buffer overflow vulnerability [CWE-122] in FortiOS SSL-VPN 7.2.0 through 7.2.2, 7.0.0 through 7.0.8, 6.4.0 through 6.4.10, 6.2.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 7.2.3
None on Exploit-DB, Metasploit or GitHub

Summary

FortiOS and FortiProxy SSL-VPN components from Fortinet are affected by this flaw. A remote attacker without authentication could send specially crafted requests to run arbitrary code or commands on the affected device.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

A heap-based buffer overflow vulnerability [CWE-122] in FortiOS SSL-VPN 7.2.0 through 7.2.2, 7.0.0 through 7.0.8, 6.4.0 through 6.4.10, 6.2.0 through 6.2.11, 6.0.15 and earlier and FortiProxy SSL-VPN 7.2.0 through 7.2.1, 7.0.7 and earlier may allow a remote unauthenticated attacker to execute arbitrary code or commands via specifically crafted requests.

Timeline

  1. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  2. CVE published
  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Fortinet FortiProxy

    From 7.2.0 · through 7.2.1; From 7.0.0 · through 7.0.7; From 2.0.0 · through 2.0.11; From 1.2.0 · through 1.2.13; From 1.1.0 · through 1.1.6; From 1.0.0 · through 1.0.7

  • Fortinet FortiOS

    From 7.2.0 · through 7.2.2; From 7.0.0 · through 7.0.8; From 6.4.0 · through 6.4.10; From 6.2.0 · through 6.2.11; From 6.0.0 · through 6.0.15; From 5.6.0 · through 5.6.14; From 5.4.0 · through 5.4.13; From 5.2.0 · through 5.2.15; From 5.0.0 · through 5.0.14

References 1

fortiguard.com

FAQ

Questions about CVE-2022-42475

What does this mean?

A heap-based buffer overflow in FortiOS SSL-VPN lets a remote attacker who has not logged in run arbitrary code or commands on the device by sending specially crafted requests.Source: fortiguard.com

Am I affected, and how do I check?

Affected versions are FortiOS SSL-VPN 7.2.0 through 7.2.2, 7.0.0 through 7.0.8, 6.4.0 through 6.4.10, 6.2.0 through 6.2.11 and 6.0.0 through 6.0.15, and FortiProxy SSL-VPN 7.2.0 through 7.2.1 and 7.0.0 through 7.0.7. To check, compare the firmware version shown in the device's system status with these ranges and confirm whether SSL-VPN is enabled.Source: fortiguard.com

What should I do about it?

Upgrade FortiOS to 7.2.3 or above, or upgrade FortiProxy to 7.2.2 or above as the advisory states. Until the upgrade is done, disable SSL-VPN, which is the listed workaround.Source: fortiguard.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-12-13, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data