Skip to main content
← All vulnerabilities
CVE-2022-4135GHSA-995F-9X5R-2RCJ

Heap buffer overflow in GPU in Google Chrome prior to 107.0.5304.121 allowed a remote attacker who had compromised the renderer process to p

Affects Google Chrome before 107.0.5304.121 and Electron 19.0.0 through 19.1.8. CVSS rates it critical at 9.6. Fixed in Chrome 107.0.5304.121 and Electron 19.1.8.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 107.0.5304.121, 19.1.8
None on Exploit-DB, Metasploit or GitHub

Summary

Google Chrome, the web browser, is affected by this vulnerability, which is a memory flaw in its GPU component. An attacker who had already compromised the browser's renderer process could potentially use a specially crafted web page to escape the browser's sandbox protections.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Heap buffer overflow in GPU in Google Chrome prior to 107.0.5304.121 allowed a remote attacker who had compromised the renderer process to potentially perform a sandbox escape via a crafted HTML page. (Chromium security severity: High)

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Google Chrome

    From unspecified · fixed in 107.0.5304.121

  • electronnpm

    From 19.0.0 · fixed in 19.1.8

References 3

chromereleases.googleblog.com

crbug.com

security.gentoo.org

FAQ

Questions about CVE-2022-4135

What should I do about it?

Upgrade Google Chrome to 107.0.5304.121 or later, or Electron to 19.1.8 or later. The checked facts also list 109.0.5414.74 as a fix version, from a Gentoo google-chrome package reference.Source: security.gentoo.org

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-11-28, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data