Skip to main content
← All vulnerabilities
CVE-2022-35914

/vendor/htmlawed/htmlawed/htmLawedTest.php in the htmlawed module for GLPI through 10.0.2 allows PHP code injection.

Affects GLPI versions below 10.0.3 and below 9.5.9 through the htmlawed module's test script. Fixed in GLPI 10.0.3 and 9.5.9.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 10.0.3, 9.5.9
None on Exploit-DB, Metasploit or GitHub

Summary

The htmlawed module used by GLPI (an IT asset and service management application) contains a test script that can be abused to inject and run arbitrary PHP code on the server. A successful attack could allow an attacker to execute commands and take control of the affected GLPI installation.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

/vendor/htmlawed/htmlawed/htmLawedTest.php in the htmlawed module for GLPI through 10.0.2 allows PHP code injection.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • n/a n/a

    Version range not reported

References 7

bioinformatics.org

GitHub · glpi-project/glpi

glpi-project.org

packetstormsecurity.com

GitHub · Orange-Cyberdefense/CVE-repository

mayfly277.github.io

FAQ

Questions about CVE-2022-35914

What does this mean?

The htmlawed test script htmLawedTest.php in GLPI allows PHP code injection. The advisory describes the impact as remote code execution without authentication.Source: github.com

Am I affected, and how do I check?

The advisory lists GLPI versions below 10.0.3 and below 9.5.9 as affected. The affected file is vendor/htmlawed/htmlawed/htmLawedTest.php within the GLPI installation, so check the GLPI version and whether that file is present.Source: github.com

What should I do about it?

Upgrade GLPI to 10.0.3 or 9.5.9, depending on the release line in use. The sources provided do not list a workaround.Source: github.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2023-03-07, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data