Skip to main content
← All vulnerabilities
CVE-2022-32917

The issue was addressed with improved bounds checks.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 16, 11.7, 15.7, 12.6
None on Exploit-DB, Metasploit or GitHub

Summary

Apple's macOS, iOS, and iPadOS operating systems are affected. A malicious app could exploit this flaw to run its own code with kernel-level privileges, giving it control over the core of the device.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

The issue was addressed with improved bounds checks. This issue is fixed in macOS Monterey 12.6, iOS 15.7 and iPadOS 15.7, iOS 16, macOS Big Sur 11.7. An application may be able to execute arbitrary code with kernel privileges. Apple is aware of a report that this issue may have been actively exploited..

Timeline

  1. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  2. CVE published
  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated

Affected versions

  • Apple iOS

    From unspecified · fixed in 16

  • Apple macOS

    From unspecified · fixed in 11.7

  • Apple macOS

    From unspecified · fixed in 15.7

  • Apple macOS

    From unspecified · fixed in 12.6

References 8

support.apple.com

seclists.org

FAQ

Questions about CVE-2022-32917

What does this mean?

An application may be able to execute arbitrary code with kernel privileges. The advisory says the flaw was addressed with improved bounds checks.Source: support.apple.com

Am I affected, and how do I check?

Apple lists iOS and macOS as affected before the fixed versions: iOS before 16, macOS before 11.7, macOS before 12.6, and macOS before 15.7. To check a Mac, open the Apple menu and choose About This Mac to see the macOS version; on an iPhone or iPad, check Settings, General, About, and the iOS version.Source: support.apple.com

What should I do about it?

Update iOS to version 16 or later, and update macOS to 11.7, 12.6, or 15.7 depending on the release line in use. Install the latest update available for your device.Source: support.apple.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-09-14, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data