Skip to main content
← All vulnerabilities
CVE-2022-32893

An out-of-bounds write issue was addressed with improved bounds checking.

Affects Safari and iOS and iPadOS before 15.6, and macOS before 12.5. The fix is in Safari and iOS and iPadOS 15.6 and macOS 12.5.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 15.6, 12.5
None on Exploit-DB, Metasploit or GitHub

Summary

This vulnerability affects Apple's iOS, iPadOS, macOS Monterey, and Safari. A specially crafted web page processed by these systems could allow an attacker to run arbitrary code on the device.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

An out-of-bounds write issue was addressed with improved bounds checking. This issue is fixed in iOS 15.6.1 and iPadOS 15.6.1, macOS Monterey 12.5.1, Safari 15.6.1. Processing maliciously crafted web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited.

Timeline

  1. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  2. CVE published
  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated

Affected versions

  • Apple Safari

    From unspecified · fixed in 15.6

  • Apple iOS and iPadOS

    From unspecified · fixed in 15.6

  • Apple macOS

    From unspecified · fixed in 12.5

References 17

support.apple.com

openwall.com

lists.fedoraproject.org

debian.org

lists.debian.org

security.gentoo.org

seclists.org

FAQ

Questions about CVE-2022-32893

What does this mean?

The bug is an out-of-bounds write, meaning software writes data outside the memory area meant for it. Apple fixed it with improved bounds checking. The advisory says crafted web content may lead to arbitrary code execution.Source: lists.debian.org

Am I affected, and how do I check?

Safari and iOS and iPadOS versions before 15.6 are listed as affected, and macOS versions before 12.5 are listed as affected. To check, compare the installed version of each product with these fixed versions.Source: lists.debian.org

What should I do about it?

Update Safari and iOS and iPadOS to 15.6 or later, and macOS to 12.5 or later.Source: lists.debian.org

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-08-18, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data