Improper Control of Generation of Code in jai-ext
Programs using the jt-jiffle module that accept Jiffle scripts over a network request are affected, including the downstream GeoServer project. A patch is available in a later jai-ext release.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 1.1.22
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
JAI-EXT, an open-source extension of the Java Advanced Imaging API, is affected, and so is the downstream GeoServer project that uses it. An attacker who can supply Jiffle scripts through a network request could potentially run arbitrary code on the affected server.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
JAI-EXT is an open-source project which aims to extend the Java Advanced Imaging (JAI) API. Programs allowing Jiffle script to be provided via network request can lead to a Remote Code Execution as the Jiffle script is compiled into Java code via Janino, and executed. In particular, this affects the downstream GeoServer project. Version 1.2.22 will contain a patch that disables the ability to inject malicious code into the resulting script. Users unable to upgrade may negate the ability to compile Jiffle scripts from the final application, by removing janino-x.y.z.jar from the classpath.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- geosolutions-it jai-ext
fixed in 1.1.22
- it.geosolutions.jaiext.jiffle:jt-jiffleMaven
fixed in 1.1.22
- it.geosolutions.jaiext.jiffle:jt-jiffle-languageMaven
fixed in 1.1.22
References 2
GitHub · geosolutions-it/jai-ext
Questions about CVE-2022-24816
What does this mean?
Jiffle scripts are compiled into Java code via Janino and then executed. Because a script can be supplied over a network request, this can lead to remote code execution on the server.Source: github.com
Am I affected, and how do I check?
The jt-jiffle and jt-jiffle-language artifacts are listed as affected in all versions before 1.1.22. To check a deployment, look at the jt-jiffle version in the build file or classpath, and whether Jiffle script input can arrive over a network request. The downstream GeoServer project is named as affected.Source: github.com
What should I do about it?
Upgrade to the patched jai-ext release. The patch text names 1.2.22, while the version ranges list 1.1.22 as the fixed version, so confirm the target release against the advisory. Until the upgrade is done, remove janino-x.y.z.jar from the classpath to stop Jiffle scripts from being compiled in the final application.Source: github.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2024-06-26, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data