Skip to main content
← All vulnerabilities
CVE-2022-1388

On F5 BIG-IP 16.1.x versions prior to 16.1.2.2, 15.1.x versions prior to 15.1.5.1, 14.1.x versions prior to 14.1.4.6, 13.1.x versions prior

Affects F5 BIG-IP 16.1.0 to 16.1.2 and 15.1.0 to 15.1.5, plus older 11.6 to 14.1 branches. Fixed in 16.1.2.2, 15.1.5.1, 14.1.4.6, and 13.1.5.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 16.1.2.2, 15.1.5.1, 14.1.4.6, 13.1.5
None on Exploit-DB, Metasploit or GitHub

Summary

The affected software is F5 BIG-IP, a network traffic management product, in multiple older release branches. An attacker could send specially crafted requests that bypass authentication on the iControl REST management interface, potentially gaining unauthorized access to manage the device.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

On F5 BIG-IP 16.1.x versions prior to 16.1.2.2, 15.1.x versions prior to 15.1.5.1, 14.1.x versions prior to 14.1.4.6, 13.1.x versions prior to 13.1.5, and all 12.1.x and 11.6.x versions, undisclosed requests may bypass iControl REST authentication. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • F5 BIG-IP

    From 16.1.x · fixed in 16.1.2.2; From 15.1.x · fixed in 15.1.5.1; From 14.1.x · fixed in 14.1.4.6; From 13.1.x · fixed in 13.1.5; From 12.1.x · through 12.1.6; From 11.6.x · through 11.6.5

References 5

support.f5.com

packetstormsecurity.com

secpod.com

FAQ

Questions about CVE-2022-1388

What does this mean?

The iControl REST component can be bypassed for authentication, which allows commands to run on the device with the highest privileges.Source: secpod.com

Am I affected, and how do I check?

The listed ranges are BIG-IP 16.1.0 to 16.1.2 and 15.1.0 to 15.1.5, plus older 14.1, 13.1, 12.1 and 11.6 releases up to their listed last affected versions. Compare the BIG-IP version reported by the device against these ranges.Source: secpod.com

What should I do about it?

Upgrade to 16.1.2.2 on the 16.x branch, 15.1.5.1 on 15.x, 14.1.4.6 on 14.x, or 13.1.5 on 13.x. On 12.1 and 11.6, the listed last affected versions are 12.1.6 and 11.6.5, so move to a release outside those ranges.Source: secpod.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-05-10, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data