Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
Affects Apache Log4j2 versions earlier than 2.15.0 when message lookup substitution is enabled. The fix is in 2.15.0.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in log4j-core*, 2.15.0, 2.3.1, 2.12.2, 1.9.2, and 3 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Apache Log4j2, a widely used Java logging library, is affected, and an attacker who can control logged messages or their parameters may be able to run arbitrary code loaded from malicious LDAP or other JNDI servers. This could allow full compromise of the system running the affected software.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Apache Log4j2 2.0-beta9 through 2.15.0 (excluding security releases 2.12.2, 2.12.3, and 2.3.1) JNDI features used in configuration, log messages, and parameters do not protect against attacker controlled LDAP and other JNDI related endpoints. An attacker who can control log messages or log message parameters can execute arbitrary code loaded from LDAP servers when message lookup substitution is enabled. From log4j 2.15.0, this behavior has been disabled by default. From version 2.16.0 (along with 2.12.2, 2.12.3, and 2.3.1), this functionality has been completely removed. Note that this vulnerability is specific to log4j-core and does not affect log4net, log4cxx, or other Apache Logging Services projects.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- Apache Software Foundation Apache Log4j2
From 2.0-beta9 · fixed in log4j-core*
- org.apache.logging.log4j:log4j-coreMaven
From 2.13.0 · fixed in 2.15.0
- org.apache.logging.log4j:log4j-coreMaven
From 2.0-beta9 · fixed in 2.3.1
- org.apache.logging.log4j:log4j-coreMaven
From 2.4 · fixed in 2.12.2
- com.guicedee.services:log4j-coreMaven
through 1.2.1.2-jre17
- org.xbib.elasticsearch:log4jMaven
6.3.2.1
- uk.co.nichesolutions.logging.log4j:log4j-coreMaven
2.6.3-CUSTOM
- org.ops4j.pax.logging:pax-logging-log4j2Maven
From 1.8.0 · fixed in 1.9.2
- org.ops4j.pax.logging:pax-logging-log4j2Maven
From 1.10.0 · fixed in 1.10.8
- org.ops4j.pax.logging:pax-logging-log4j2Maven
From 1.11.0 · fixed in 1.11.10
- org.ops4j.pax.logging:pax-logging-log4j2Maven
From 2.0.0 · fixed in 2.0.11
References 23
logging.apache.org
openwall.com
security.netapp.com
packetstormsecurity.com
psirt.global.sonicwall.com
debian.org
lists.debian.org
lists.fedoraproject.org
msrc-blog.microsoft.com
kb.cert.org
twitter.com
cert-portal.siemens.com
Questions about CVE-2021-44228
What does this mean?
An attacker who can control log messages or log message parameters can make the application execute arbitrary code loaded from LDAP servers. The issue is that Log4j2's JNDI features do not restrict attacker-controlled LDAP and other JNDI endpoints.Source: lists.debian.org, sec.cloudapps.cisco.com
Am I affected, and how do I check?
Log4j2 versions earlier than 2.15.0 are affected when message lookup substitution is enabled. Several related packages are listed separately, including pax-logging-log4j2 in the 1.8.0 to 1.9.2, 1.10.0 to 1.10.8, 1.11.0 to 1.11.10, and 2.0.0 to 2.0.11 ranges. To check, look at the log4j-core version in the project's dependencies and whether message lookup substitution is enabled.Source: lists.debian.org, sec.cloudapps.cisco.com
What should I do about it?
Upgrade log4j-core to 2.15.0 or later. For Debian bullseye, the fixed package version is 2.15.0-1~deb11u1.Source: lists.debian.org, sec.cloudapps.cisco.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2021-12-10, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data