An issue has been discovered in GitLab CE/EE affecting all versions starting from 10.5 before 14.3.6, all versions starting from 14.4 before
Affects GitLab CE/EE 10.5 through 14.3.x, 14.4.x before 14.4.4, and 14.5.x before 14.5.2 when sign-ups are enabled and new users default to external. Fixed in those releases.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 14.3.6, 14.4.4, 14.5.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
GitLab Community Edition and Enterprise Edition are affected. An unauthorized external user could abuse the CI Lint API to make the server send requests on their behalf, which could expose internal resources.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 10.5 before 14.3.6, all versions starting from 14.4 before 14.4.4, all versions starting from 14.5 before 14.5.2. Unauthorized external users could perform Server Side Requests via the CI Lint API
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- Record last updated
- CISA remediation deadline
Due date for US federal agencies to patch
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- GitLab GitLab
From 10.5 · fixed in 14.3.6; From 14.4 · fixed in 14.4.4; From 14.5 · fixed in 14.5.2
References 3
Questions about CVE-2021-39935
What does this mean?
The CI Lint API can be abused to make the GitLab server send requests to addresses it should not reach, a server-side request forgery (SSRF). This can expose information and bypass protections.Source: gitlab.com
Am I affected, and how do I check?
Affected versions are 10.5 up to 14.3.6, 14.4 up to 14.4.4, and 14.5 up to 14.5.2. The advisory's conditions are that sign-ups are enabled and new users are set to external by default; to check, compare your GitLab version and the sign-up and external-user settings in the Admin Area.Source: gitlab.com
What should I do about it?
Upgrade to 14.3.6, 14.4.4, or 14.5.2, matching your release branch. Those are the fixed versions listed for this vulnerability.Source: gitlab.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-02-03, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data