Skip to main content
← All vulnerabilities
CVE-2021-3560

It was found that polkit could be tricked into bypassing the credential checks for D-Bus requests, elevating the privileges of the requestor

Affects polkit from 0.113 onward when a calling process disconnects from dbus-daemon at the wrong moment and the caller skips an error check. Fixed in polkit 0.119.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 0.119
None on Exploit-DB, Metasploit or GitHub

Summary

Polkit, a system component that manages authorization for privileged actions on Linux systems, is affected by this flaw. A local user with no special privileges could exploit it to gain root access, allowing them to create new administrator accounts and compromise the confidentiality, integrity, and availability of the system.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

It was found that polkit could be tricked into bypassing the credential checks for D-Bus requests, elevating the privileges of the requestor to the root user. This flaw could be used by an unprivileged local attacker to, for example, create a new local administrator. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • n/a polkit

    polkit 0.119

References 4

bugzilla.redhat.com

github.blog

packetstormsecurity.com

FAQ

Questions about CVE-2021-3560

What does this mean?

A local process can disconnect from the D-Bus message daemon at a precise moment, which tricks polkit into skipping its credential check on the request. The request then runs with root privileges, so an unprivileged local user can perform actions such as installing packages or creating new administrators.Source: bugzilla.redhat.com, github.blog

Am I affected, and how do I check?

The flaw is in polkit starting from version 0.113, and the advisory names RHEL 8 and Fedora 21 or later among vulnerable distributions. The bug needs calling code that does not check whether polkit_system_bus_name_get_creds_sync set an error, so check your installed polkit version with pkaction --version.Source: bugzilla.redhat.com, github.blog

What should I do about it?

Upgrade polkit to version 0.119 or later, which contains the fix. Install the update from your distribution's package manager.Source: bugzilla.redhat.com, github.blog

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2023-05-12, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data