Skip to main content
← All vulnerabilities
CVE-2021-32648GHSA-MXR5-MC97-63RC

Account Takeover in Octobercms

Affects October CMS october/system versions 1.0.471 and 1.1.1, where an attacker who knows an administrator's username can use the password reset form. Fixed in build 472 and v1.1.5.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 1.0.472, 1.1.5
None on Exploit-DB, Metasploit or GitHub

Summary

OctoberCMS, a content management platform built on the Laravel PHP framework, is affected by this vulnerability. An attacker could exploit a flaw in the password reset process to take over user accounts.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

octobercms in a CMS platform based on the Laravel PHP Framework. In affected versions of the october/system package an attacker can request an account password reset and then gain access to the account using a specially crafted request. The issue has been patched in Build 472 and v1.1.5.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • octobercms october

    From 1.0.471 · fixed in 1.0.472; From 1.1.1 · fixed in 1.1.5

  • october/systemPackagist

    fixed in 1.0.472

  • october/systemPackagist

    From 1.1.1 · fixed in 1.1.5

References 3

GitHub · octobercms/october

GitHub · octobercms/library

FAQ

Questions about CVE-2021-32648

What does this mean?

An attacker who knows an administrator's username can request a password reset and use a specially crafted request to gain access to that account, including administrator accounts.Source: github.com

Am I affected, and how do I check?

The advisory lists october/system versions 1.0.471 and 1.1.1 as affected, and the affected ranges run from version 0 up to build 472 and from 1.1.1 up to 1.1.5. Check the installed october/system version in composer.lock or the October CMS backend version display.Source: github.com

What should I do about it?

Upgrade to build 472 on the 1.0.x line or to v1.1.5 on the 1.1.x line. The advisory also gives a manual workaround of applying octobercms/library commits 016a297 and 5bd1a28 to the installation.Source: github.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-01-18, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data