Skip to main content
← All vulnerabilities
CVE-2021-30869

A type confusion issue was addressed with improved state handling.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 14.4, 11.2, 12.5, 2021
None on Exploit-DB, Metasploit or GitHub

Summary

Apple iOS, iPadOS, and macOS are affected. A malicious app could exploit this flaw to run arbitrary code with kernel-level privileges, giving it control over the entire device.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

A type confusion issue was addressed with improved state handling. This issue is fixed in iOS 12.5.5, iOS 14.4 and iPadOS 14.4, macOS Big Sur 11.2, Security Update 2021-001 Catalina, Security Update 2021-001 Mojave, Security Update 2021-006 Catalina. A malicious application may be able to execute arbitrary code with kernel privileges. Apple is aware of reports that an exploit for this issue exists in the wild.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated

Affected versions

  • Apple iOS and iPadOS

    From unspecified · fixed in 14.4

  • Apple macOS

    From unspecified · fixed in 11.2

  • Apple macOS

    From unspecified · fixed in 12.5

  • Apple macOS

    From unspecified · fixed in 2021

References 4

support.apple.com

FAQ

Questions about CVE-2021-30869

What does this mean?

A type confusion issue was addressed with improved state handling. Apple's impact statement says a malicious application may be able to execute arbitrary code with kernel privileges.Source: support.apple.com

Am I affected, and how do I check?

Apple lists iOS and iPadOS as fixed in 14.4, and macOS as fixed in 11.2, 12.5, and a release listed only as 2021. To check a device, look at the version under Settings > General > About on iOS or iPadOS, or About This Mac on macOS.Source: support.apple.com

What should I do about it?

Install the fixed release for the affected product, as listed in Apple's advisory: 14.4 or later for iOS and iPadOS, and 11.2 or 12.5 or later for macOS. The advisory also names iOS 12.5.5 as a fix.Source: support.apple.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2021-11-03, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data