Skip to main content
← All vulnerabilities
CVE-2021-27860

Arbitrary file upload vulnerability in FatPipe software

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 10.1.2r60p92, 10.2.2r44p1
None on Exploit-DB, Metasploit or GitHub

Summary

FatPipe WARP, IPVPN, and MPVPN software is affected by this vulnerability. A remote attacker without logging in can exploit the web management interface to upload files to any location on the device's filesystem.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

A vulnerability in the web management interface of FatPipe WARP, IPVPN, and MPVPN software prior to versions 10.1.2r60p92 and 10.2.2r44p1 allows a remote, unauthenticated attacker to upload a file to any location on the filesystem. The FatPipe advisory identifier for this vulnerability is FPSA006.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • FatPipe WARP

    From 10.1 · fixed in 10.1.2r60p92; From 10.2 · fixed in 10.2.2r44p1

  • FatPipe IPVPN

    From 10.1 · fixed in 10.1.2r60p92; From 10.2 · fixed in 10.2.2r44p1

  • FatPipe MPVPN

    From 10.1 · fixed in 10.1.2r60p92; From 10.2 · fixed in 10.2.2r44p1

References 2

fatpipeinc.com

ic3.gov

FAQ

Questions about CVE-2021-27860

What does this mean?

The flaw lets a remote attacker upload a file to any location on the filesystem of an affected FatPipe device. The advisory describes the impact as the attacker placing files anywhere on the device's storage.Source: fatpipeinc.com

Am I affected, and how do I check?

Affected products are FatPipe WARP, MPVPN and IPVPN running software version 10 before the fixed releases: 10.1.2r60p92 for the 10.1 line and 10.2.2r44p1 for the 10.2 line. Compare your installed software version against these to see whether it falls in the affected range.Source: fatpipeinc.com

What should I do about it?

Upgrade to 10.1.2r60p92 or later for the 10.1 line, or to 10.2.2r44p1 or later for the 10.2 line. If you cannot upgrade yet, see the mitigation for the interim step.Source: fatpipeinc.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-01-10, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data