Skip to main content
← All vulnerabilities
CVE-2021-26085

Affected versions of Atlassian Confluence Server allow remote attackers to view restricted resources via a Pre-Authorization Arbitrary File

Confluence Server and Data Center before 7.4.10, and 7.5.0 through 7.12.2, are affected. Fixed in 7.4.10, 7.12.3, and 7.13.0.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 7.4.10, 7.12.3
None on Exploit-DB, Metasploit or GitHub

Summary

Atlassian Confluence Server is affected, allowing remote attackers without logging in to read restricted files on the server. This could expose sensitive information stored on the affected system.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Affected versions of Atlassian Confluence Server allow remote attackers to view restricted resources via a Pre-Authorization Arbitrary File Read vulnerability in the /s/ endpoint. The affected versions are before version 7.4.10, and from version 7.5.0 before 7.12.3.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Atlassian Confluence Server

    From unspecified · fixed in 7.4.10; From 7.5.0 · fixed in unspecified; From unspecified · fixed in 7.12.3

  • Atlassian Confluence Data Center

    From unspecified · fixed in 7.4.10; From 7.5.0 · fixed in unspecified; From unspecified · fixed in 7.12.3

References 2

jira.atlassian.com

packetstormsecurity.com

FAQ

Questions about CVE-2021-26085

What does this mean?

The flaw is an arbitrary file read in the /s/ endpoint that needs no prior login, letting remote attackers view restricted resources.Source: jira.atlassian.com

Am I affected, and how do I check?

Confluence Server and Confluence Data Center versions before 7.4.10, and versions from 7.5.0 up to before 7.12.3, are affected. Compare the installed version number against these ranges.Source: jira.atlassian.com

What should I do about it?

Upgrade to 7.4.10, 7.12.3, or 7.13.0, depending on which release line you run.Source: jira.atlassian.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-03-28, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data