In affected versions of Confluence Server and Data Center, an OGNL injection vulnerability exists that would allow an unauthenticated attack
Affects Confluence Server and Data Center before 6.13.23, 6.14.0 to before 7.4.11, 7.5.0 to before 7.11.6, and 7.12.0 to before 7.12.5. Fixed in 6.13.23, 7.4.11, 7.11.6, 7.12.5, and 7.13.0.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 6.13.23, 7.4.11, 7.11.6, 7.12.5
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Confluence Server and Data Center, Atlassian's self-hosted collaboration and wiki software, are affected. An unauthenticated attacker could exploit this flaw to run arbitrary code on the server, potentially gaining full control of the Confluence instance and its data.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
In affected versions of Confluence Server and Data Center, an OGNL injection vulnerability exists that would allow an unauthenticated attacker to execute arbitrary code on a Confluence Server or Data Center instance. The affected versions are before version 6.13.23, from version 6.14.0 before 7.4.11, from version 7.5.0 before 7.11.6, and from version 7.12.0 before 7.12.5.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- Atlassian Confluence Server
From unspecified · fixed in 6.13.23; From 6.14.0 · fixed in unspecified; From unspecified · fixed in 7.4.11; From 7.5.0 · fixed in unspecified; From unspecified · fixed in 7.11.6; From 7.12.0 · fixed in unspecified; From unspecified · fixed in 7.12.5
- Atlassian Confluence Data Center
From unspecified · fixed in 6.13.23; From 6.14.0 · fixed in unspecified; From unspecified · fixed in 7.4.11; From 7.5.0 · fixed in unspecified; From unspecified · fixed in 7.11.6; From 7.12.0 · fixed in unspecified; From unspecified · fixed in 7.12.5
References 2
jira.atlassian.com
packetstormsecurity.com
Questions about CVE-2021-26084
What does this mean?
The bug is an OGNL injection flaw, meaning Confluence can be made to evaluate attacker-supplied OGNL expressions. The advisory says an unauthenticated attacker could use this to execute arbitrary code on the Confluence Server or Data Center instance.Source: jira.atlassian.com
Am I affected, and how do I check?
Affected versions are Confluence Server and Confluence Data Center before 6.13.23, 6.14.0 up to before 7.4.11, 7.5.0 up to before 7.11.6, and 7.12.0 up to before 7.12.5. Compare the installed version against these ranges.Source: jira.atlassian.com
What should I do about it?
Upgrade to the fixed release for your version line: 6.13.23, 7.4.11, 7.11.6, 7.12.5, or 7.13.0.Source: jira.atlassian.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2021-11-03, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data