Skip to main content
← All vulnerabilities
CVE-2021-22205

An issue has been discovered in GitLab CE/EE affecting all versions starting from 11.9.

Affects GitLab CE and EE from 11.9 onward. Fixed in 13.8.8, 13.9.6 and 13.10.3, matching each release line.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 13.8.8, 13.9.6, 13.10.3
None on Exploit-DB, Metasploit or GitHub

Summary

GitLab Community Edition and Enterprise Edition are affected, including all releases from 11.9 onward. An attacker could exploit improper image file validation in a file parser to execute arbitrary commands remotely on the server.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 11.9. GitLab was not properly validating image files that were passed to a file parser which resulted in a remote command execution.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • GitLab GitLab

    From 11.9 · fixed in 13.8.8; From 13.9 · fixed in 13.9.6; From 13.10 · fixed in 13.10.3

References 5

hackerone.com

gitlab.com

packetstormsecurity.com

FAQ

Questions about CVE-2021-22205

What does this mean?

Uploaded files with jpg, jpeg or tiff extensions are passed to ExifTool to remove metadata. ExifTool decides the file type from its content, so a renamed file can reach other parsers such as DjVu. The advisory describes the impact as remote command execution on the server through Perl code embedded in an uploaded file.Source: gitlab.com

Am I affected, and how do I check?

GitLab CE and EE from 11.9 are affected, up to the fixed releases: 13.8.8 on the 13.8 line, 13.9.6 on the 13.9 line, and 13.10.3 on the 13.10 line. To check an installation, compare its GitLab version with these ranges.Source: gitlab.com

What should I do about it?

Upgrade to 13.8.8, 13.9.6 or 13.10.3, whichever matches the release line in use, or to a later release.Source: gitlab.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2021-11-03, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data