When requests to the internal network for webhooks are enabled, a server-side request forgery vulnerability in GitLab affecting all versions
Only GitLab 10.5 through 13.6.x, 13.7.0 through 13.7.6, and 13.8.0 through 13.8.3 are in range, and only where an admin has enabled internal webhook requests. CVSS rates it 6.8 (medium). Fixed in 13.6.7, 13.7.7, and 13.8.4.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 13.6.7, 13.7.7, 13.8.4
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: active
- Automatable: no
- Technical impact: total
Summary
GitLab is affected when its setting allowing webhook requests to the internal network is enabled. An unauthenticated attacker can abuse a server-side request forgery flaw to make the GitLab server send requests to internal systems, even on instances where self-registration is disabled.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
When requests to the internal network for webhooks are enabled, a server-side request forgery vulnerability in GitLab affecting all versions starting from 10.5 was possible to exploit for an unauthenticated attacker even on a GitLab instance where registration is disabled
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA SSVC assessment
Exploitation: active · Automatable: no · Technical impact: total
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- GitLab GitLab
From 10.5 · fixed in 13.6.7; From 13.7 · fixed in 13.7.7; From 13.8 · fixed in 13.8.4
- gitlabBitnami
From 10.5.0 · fixed in 13.6.7; From 13.7.0 · fixed in 13.7.7; From 13.8.0 · fixed in 13.8.4
References 3
Questions about CVE-2021-22175
What does this mean?
An unauthenticated user can make GitLab send server-side requests into the internal network. This can also reveal the GitLab instance's origin IP address and user agent.Source: gitlab.com
Am I affected, and how do I check?
Affected versions are GitLab 10.5.0 up to 13.6.7, 13.7.0 up to 13.7.7, and 13.8.0 up to 13.8.4. The setup must have internal requests enabled for Webhooks, and the CI Lint API endpoint must be reachable without authentication. Check the installed version in the GitLab admin area and the internal-requests setting under the Webhooks options.Source: gitlab.com
What should I do about it?
Upgrade to the fixed release for your branch: 13.6.7, 13.7.7, or 13.8.4.Source: gitlab.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-02-18, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data