SSRF in adminer
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 4.7.9
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Adminer, an open-source database management tool distributed as a single PHP file, is affected, particularly the builds that include all database drivers. An attacker could abuse the flaw to make the server send requests to internal or other unintended destinations, potentially exposing internal resources.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Adminer is an open-source database management in a single PHP file. In adminer from version 4.0.0 and before 4.7.9 there is a server-side request forgery vulnerability. Users of Adminer versions bundling all drivers (e.g. `adminer.php`) are affected. This is fixed in version 4.7.9.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- vrana adminer
From 4.0.0 · fixed in 4.7.9
- vrana/adminerPackagist
fixed in 4.7.9
References 5
GitHub · vrana/adminer
packagist.org
lists.debian.org
Questions about CVE-2021-21311
What does this mean?
The server-side request forgery flaw means Adminer can be made to send requests to a destination other than the one it was expected to contact. The software does not sufficiently check that the request goes to the intended destination.Source: github.com
Am I affected, and how do I check?
Adminer versions from 4.0.0 up to but not including 4.7.9 are affected, but only builds that bundle all drivers, such as adminer.php. To check, look at the file name of the Adminer build in use and the version it reports on its login page.Source: github.com
What should I do about it?
Upgrade Adminer to version 4.7.9 or later, which contains the fix. Until the upgrade is done, a single-driver build such as adminer-mysql.php can be used instead.Source: github.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-09-29, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data