Insufficient validation of untrusted input in V8 in Google Chrome prior to 89.0.4389.128 allowed a remote attacker to potentially exploit he
Google Chrome builds for x86_64 before 89.0.4389.128 are in scope. Chromium's fix is the update to 90.0.4430.93.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 89.0.4389.128
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The vulnerability affects Google Chrome's V8 JavaScript engine. A remote attacker could potentially exploit it by getting a user to open a specially crafted web page, which could corrupt memory and may allow the attacker to compromise the browser.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Insufficient validation of untrusted input in V8 in Google Chrome prior to 89.0.4389.128 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- Google Chrome
From unspecified · fixed in 89.0.4389.128
References 8
chromereleases.googleblog.com
crbug.com
security.gentoo.org
packetstormsecurity.com
lists.fedoraproject.org
Questions about CVE-2021-21220
What does this mean?
V8, Chrome's JavaScript engine, does not properly validate untrusted input. The advisory says a remote attacker could potentially exploit this flaw.Source: lists.fedoraproject.org
Am I affected, and how do I check?
Google Chrome versions prior to 89.0.4389.128 are listed as affected, and the bug entry is specific to x86_64 builds. To check, open the browser's version page (chrome://version) and compare the version and build type with these.Source: lists.fedoraproject.org
What should I do about it?
Update Chrome to 90.0.4430.93, which the fix note names as the update to apply. Versions from 89.0.4389.128 onward are listed as fixed.Source: lists.fedoraproject.org
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2021-11-03, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data