Skip to main content
← All vulnerabilities
CVE-2021-1498

Cisco HyperFlex HX Command Injection Vulnerabilities

Cisco HyperFlex HX Data Platform software running a release earlier than 4.0, or 4.0 before 4.0(2e) or 4.5 before 4.5(2a), is affected. The fix is to migrate to 4.0(2e).

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 4.0(2e)
None on Exploit-DB, Metasploit or GitHub

Summary

Cisco HyperFlex HX, a hyperconverged infrastructure product, is affected through its web-based management interface. An unauthenticated remote attacker could exploit these flaws to inject and run operating system commands on the affected device.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Multiple vulnerabilities in the web-based management interface of Cisco HyperFlex HX could allow an unauthenticated, remote attacker to perform command injection attacks against an affected device. For more information about these vulnerabilities, see the Details section of this advisory.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Cisco Cisco HyperFlex HX Data Platform

    Version range not reported

References 2

tools.cisco.com

packetstormsecurity.com

FAQ

Questions about CVE-2021-1498

What does this mean?

A flaw in the HyperFlex HX software lets a command injection attack run arbitrary commands on the device. Commands run as the tomcat8 user.Source: sec.cloudapps.cisco.com

Am I affected, and how do I check?

The bug affects Cisco HyperFlex HX Data Platform software running earlier than 4.0, or 4.0 before 4.0(2e), or 4.5 before 4.5(2a). To check, compare the installed HX Data Platform release against these ranges.Source: sec.cloudapps.cisco.com

What should I do about it?

Migrate to 4.0(2e).Source: sec.cloudapps.cisco.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2021-11-03, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data