Skip to main content
← All vulnerabilities
CVE-2020-5410GHSA-32XF-JWMV-9HF3

Directory Traversal with spring-cloud-config-server

Affects spring-cloud-config-server 2.1.0.RELEASE through 2.1.8.RELEASE and 2.2.0.RELEASE through 2.2.2.RELEASE. Fixed in 2.1.9 and 2.2.3.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 2.1.9, 2.2.3
None on Exploit-DB, Metasploit or GitHub

Summary

The spring-cloud-config-server module of Spring Cloud Config is affected by this vulnerability. An attacker can send a specially crafted URL to read arbitrary configuration files on the server, which could expose sensitive information.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Spring Cloud Config, versions 2.2.x prior to 2.2.3, versions 2.1.x prior to 2.1.9, and older unsupported versions allow applications to serve arbitrary configuration files through the spring-cloud-config-server module. A malicious user, or attacker, can send a request using a specially crafted URL that can lead to a directory traversal attack.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Spring by VMware Spring Cloud Config

    From 2.1 · fixed in 2.1.9; From 2.2 · fixed in 2.2.3

  • org.springframework.cloud:spring-cloud-config-serverMaven

    From 2.1.0 · fixed in 2.1.9

  • org.springframework.cloud:spring-cloud-config-serverMaven

    From 2.2.0 · fixed in 2.2.3

References 1

tanzu.vmware.com

FAQ

Questions about CVE-2020-5410

What does this mean?

The bug lets applications serve arbitrary configuration files through the spring-cloud-config-server module, which enables directory traversal.Source: spring.io

Am I affected, and how do I check?

Spring Cloud Config 2.1.0.RELEASE through 2.1.8.RELEASE and 2.2.0.RELEASE through 2.2.2.RELEASE are affected when the spring-cloud-config-server module is used. To check a project, look at the spring-cloud-config-server version in its build file or dependency tree.Source: spring.io

What should I do about it?

Upgrade to 2.1.9 if you are on the 2.1 line, or to 2.2.3 (2.2.3.RELEASE) if you are on the 2.2 line.Source: spring.io

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-03-25, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data